[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <alpine.LFD.2.11.1405151204090.17310@knanqh.ubzr>
Date: Thu, 15 May 2014 12:06:40 -0400 (EDT)
From: Nicolas Pitre <nicolas.pitre@...aro.org>
To: Vincent Guittot <vincent.guittot@...aro.org>
cc: Peter Zijlstra <peterz@...radead.org>,
Ingo Molnar <mingo@...hat.com>,
Daniel Lezcano <daniel.lezcano@...aro.org>,
Morten Rasmussen <morten.rasmussen@....com>,
"Rafael J. Wysocki" <rjw@...ysocki.net>,
linux-kernel <linux-kernel@...r.kernel.org>,
"linaro-kernel@...ts.linaro.org" <linaro-kernel@...ts.linaro.org>
Subject: Re: [PATCH 3/6] sched/fair.c: disambiguate existing/remaining
"capacity" usage
On Thu, 15 May 2014, Vincent Guittot wrote:
> On 14 May 2014 22:57, Nicolas Pitre <nicolas.pitre@...aro.org> wrote:
> > We have "power" (which should actually become "capacity") and "capacity"
> > which is a scaled down "capacity factor" in terms of possible tasks.
> > Let's use "capa_factor" to make room for proper usage of "capacity"
> > later.
> >
> > Signed-off-by: Nicolas Pitre <nico@...aro.org>
> > ---
> > kernel/sched/fair.c | 42 +++++++++++++++++++++---------------------
> > 1 file changed, 21 insertions(+), 21 deletions(-)
> >
> > diff --git a/kernel/sched/fair.c b/kernel/sched/fair.c
> > index 0eda4c527e..2633c42692 100644
> > --- a/kernel/sched/fair.c
> > +++ b/kernel/sched/fair.c
> > @@ -5487,7 +5487,7 @@ struct sg_lb_stats {
> > unsigned long load_per_task;
> > unsigned long group_power;
> > unsigned int sum_nr_running; /* Nr tasks running in the group */
> > - unsigned int group_capacity;
> > + unsigned int group_capa_factor;
>
> As it is mainly compared to sum_nr_running, you might rename it to
> group_nr_capacity instead of group_capa_factor
But what actual meaning would "group_nr_capacity" convey? This could be
interpreted as the total number of groups possible for example.
Nicolas
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists