[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <1403209332.2753.2.camel@joe-AO725>
Date: Thu, 19 Jun 2014 13:22:12 -0700
From: Joe Perches <joe@...ches.com>
To: Johannes Stadlinger <Johannes.Stadlinger@....de>
Cc: devel@...uxdriverproject.org,
Maximilian Eschenbacher <maximilian@...henbacher.email>,
linux-kernel@...cs.fau.de,
Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
Tugce Sirin <ztugcesirin@...il.com>,
Josh Triplett <josh@...htriplett.org>,
Neil Armstrong <superna9999@...il.com>,
Paul Gortmaker <paul.gortmaker@...driver.com>,
Vitaly Osipov <vitaly.osipov@...il.com>,
devel@...verdev.osuosl.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH 6/8] wlan-ng/prism2sta:checkpatch: Fix long lines
On Thu, 2014-06-19 at 21:20 +0200, Johannes Stadlinger wrote:
> This patch fixes all warning of checkpatch about lines over 80
> characters.
trivia:
> diff --git a/drivers/staging/wlan-ng/prism2sta.c b/drivers/staging/wlan-ng/prism2sta.c
[]
> @@ -1271,7 +1275,8 @@ void prism2sta_processing_defer(struct work_struct *data)
> HFA384x_RID_CURRENTSSID, result);
> return;
> }
> - prism2mgmt_bytestr2pstr((struct hfa384x_bytestr *) &ssid,
> + prism2mgmt_bytestr2pstr((struct hfa384x_bytestr *)
> + &ssid,
> (p80211pstrd_t *) &
> wlandev->ssid);
I don't find this better or easier to read.
Sometimes it's easier to read to cast to a
void * instead of the specific type
prism2mgmt_bytestr2pstr((void *)&ssid,
(void *)&wlandev->ssid);
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists