lists.openwall.net | lists / announce owl-users owl-dev john-users john-dev passwdqc-users yescrypt popa3d-users / oss-security kernel-hardening musl sabotage tlsify passwords / crypt-dev xvendor / Bugtraq Full-Disclosure linux-kernel linux-netdev linux-ext4 linux-hardening PHC | |
Open Source and information security mailing list archives
| ||
|
Date: Sat, 5 Jul 2014 14:25:52 -0500 From: Rob Herring <robherring2@...il.com> To: Liviu Dudau <Liviu.Dudau@....com> Cc: linux-pci <linux-pci@...r.kernel.org>, Bjorn Helgaas <bhelgaas@...gle.com>, Catalin Marinas <Catalin.Marinas@....com>, Will Deacon <Will.Deacon@....com>, Benjamin Herrenschmidt <benh@...nel.crashing.org>, Arnd Bergmann <arnd@...db.de>, linaro-kernel <linaro-kernel@...ts.linaro.org>, Tanmay Inamdar <tinamdar@....com>, Grant Likely <grant.likely@...retlab.ca>, Sinan Kaya <okaya@...eaurora.org>, Jingoo Han <jg1.han@...sung.com>, Kukjin Kim <kgene.kim@...sung.com>, Suravee Suthikulanit <suravee.suthikulpanit@....com>, Device Tree ML <devicetree@...r.kernel.org>, LKML <linux-kernel@...r.kernel.org>, LAKML <linux-arm-kernel@...ts.infradead.org> Subject: Re: [PATCH v8 4/9] pci: OF: Fix the conversion of IO ranges into IO resources. On Tue, Jul 1, 2014 at 1:43 PM, Liviu Dudau <Liviu.Dudau@....com> wrote: > The ranges property for a host bridge controller in DT describes > the mapping between the PCI bus address and the CPU physical address. > The resources framework however expects that the IO resources start > at a pseudo "port" address 0 (zero) and have a maximum size of IO_SPACE_LIMIT. > The conversion from pci ranges to resources failed to take that into account. I don't think this change is right. There are 2 resources: the PCI bus addresses and cpu addresses. This function deals with the cpu addresses. Returning pci addresses for i/o and cpu addresses for memory is going to be error prone. We probably need both cpu and pci resources exposed to host controllers. Making the new function only deal with i/o bus resources and naming it of_pci_range_to_io_resource would be better. Rob > In the process move the function into drivers/of/address.c as it now > depends on pci_address_to_pio() code and make it return an error message. > > Signed-off-by: Liviu Dudau <Liviu.Dudau@....com> > Tested-by: Tanmay Inamdar <tinamdar@....com> > --- > drivers/of/address.c | 47 ++++++++++++++++++++++++++++++++++++++++++++++ > include/linux/of_address.h | 13 ++----------- > 2 files changed, 49 insertions(+), 11 deletions(-) > > diff --git a/drivers/of/address.c b/drivers/of/address.c > index 1345733..cbbaed2 100644 > --- a/drivers/of/address.c > +++ b/drivers/of/address.c > @@ -872,3 +872,50 @@ bool of_dma_is_coherent(struct device_node *np) > return false; > } > EXPORT_SYMBOL_GPL(of_dma_is_coherent); > + > +/* > + * of_pci_range_to_resource - Create a resource from an of_pci_range > + * @range: the PCI range that describes the resource > + * @np: device node where the range belongs to > + * @res: pointer to a valid resource that will be updated to > + * reflect the values contained in the range. > + * > + * Returns EINVAL if the range cannot be converted to resource. > + * > + * Note that if the range is an IO range, the resource will be converted > + * using pci_address_to_pio() which can fail if it is called too early or > + * if the range cannot be matched to any host bridge IO space (our case here). > + * To guard against that we try to register the IO range first. > + * If that fails we know that pci_address_to_pio() will do too. > + */ > +int of_pci_range_to_resource(struct of_pci_range *range, > + struct device_node *np, struct resource *res) > +{ > + int err; > + res->flags = range->flags; > + res->parent = res->child = res->sibling = NULL; > + res->name = np->full_name; > + > + if (res->flags & IORESOURCE_IO) { > + unsigned long port = -1; > + err = pci_register_io_range(range->cpu_addr, range->size); > + if (err) > + goto invalid_range; > + port = pci_address_to_pio(range->cpu_addr); > + if (port == (unsigned long)-1) { > + err = -EINVAL; > + goto invalid_range; > + } > + res->start = port; > + } else { > + res->start = range->cpu_addr; > + } > + res->end = res->start + range->size - 1; > + return 0; > + > +invalid_range: > + res->start = (resource_size_t)OF_BAD_ADDR; > + res->end = (resource_size_t)OF_BAD_ADDR; > + return err; > +} > + > diff --git a/include/linux/of_address.h b/include/linux/of_address.h > index ac4aac4..33c0420 100644 > --- a/include/linux/of_address.h > +++ b/include/linux/of_address.h > @@ -23,17 +23,8 @@ struct of_pci_range { > #define for_each_of_pci_range(parser, range) \ > for (; of_pci_range_parser_one(parser, range);) > > -static inline void of_pci_range_to_resource(struct of_pci_range *range, > - struct device_node *np, > - struct resource *res) > -{ > - res->flags = range->flags; > - res->start = range->cpu_addr; > - res->end = range->cpu_addr + range->size - 1; > - res->parent = res->child = res->sibling = NULL; > - res->name = np->full_name; > -} > - > +extern int of_pci_range_to_resource(struct of_pci_range *range, > + struct device_node *np, struct resource *res); > /* Translate a DMA address from device space to CPU space */ > extern u64 of_translate_dma_address(struct device_node *dev, > const __be32 *in_addr); > -- > 2.0.0 > > > _______________________________________________ > linaro-kernel mailing list > linaro-kernel@...ts.linaro.org > http://lists.linaro.org/mailman/listinfo/linaro-kernel -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@...r.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists