lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Thu, 2 Nov 2017 09:12:40 +0100
From:   Simon Horman <>
To:     SF Markus Elfring <>
        Bjorn Helgaas <>,
        Laurent Pinchart <>,
        LKML <>,
Subject: Re: PCI: rcar: Use common error handling code in

On Wed, Nov 01, 2017 at 09:57:00AM +0100, SF Markus Elfring wrote:
> > This is fine by me
> Thanks for another bit of change acceptance.
> > except that the change in the name of the goto label seems spurious.
> I am curious if the popularity of a jump label like “err” will decrease
> (in the Linux source files) over time.

If your current patch bombing is successful then it will, at least in the
short term. But my comments relate to the current best practice,
not the one you seem to be trying to introduce.

> > But if you really want to change it then as it is an error path
> > I should suggest it describe that its an error and what unwinding
> > is done, f.e.  err_remove_domain.
> * Do you get such a kind of information only when the prefix “err_”
>   is added to this identifier?

Yes, err indicates its an error path.

> * Do you prefer to stress the “domain removal”
>   (or the shown error message) in the label?

I prefer to stress the unwind path as that is the most important
aspect of the error path.

I have no interest in a prelonged debate about the naming of labels.
As I pointed out its a spurious aspect of your change. If you wish me to
Ack your change then please either drop that change or update it - as I
already suggested. Else lets discontinue this sub-thread.

Powered by blists - more mailing lists