[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <c98b8f50-1adf-ea95-a91c-ec451e9fefe2@web.de>
Date: Wed, 24 Jul 2019 11:30:16 +0200
From: Markus Elfring <Markus.Elfring@....de>
To: Stephen Boyd <swboyd@...omium.org>, cocci@...teme.lip6.fr,
kernel-janitors@...r.kernel.org,
Masahiro Yamada <yamada.masahiro@...ionext.com>,
Michal Marek <michal.lkml@...kovi.net>,
Nicolas Palix <nicolas.palix@...g.fr>
Cc: Gilles Muller <Gilles.Muller@...6.fr>,
Julia Lawall <Julia.Lawall@...6.fr>,
linux-kernel@...r.kernel.org, Andrzej Hajda <a.hajda@...sung.com>,
Andy Shevchenko <andy.shevchenko@...il.com>,
Bartlomiej Zolnierkiewicz <b.zolnierkie@...sung.com>,
Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
Javier Martinez Canillas <javierm@...hat.com>,
Marek Szyprowski <m.szyprowski@...sung.com>,
Mark Brown <broonie@...nel.org>, Rob Herring <robh@...nel.org>,
Russell King <linux@...linux.org.uk>
Subject: Re: [PATCH v4 3/3] coccinelle: Add script to check for
platform_get_irq() excessive prints
I would prefer to concentrate the usage of SmPL disjunctions on changing
implementation details so that the specification of duplicate code
can be avoided.
> +(
> +platform_get_irq(E, ...)
> +|
> +platform_get_irq_byname(E, ...)
> +);
Function names:
+(platform_get_irq
+|platform_get_irq_byname
+)(E, ...);
> +if ( \( ret < 0 \| ret <= 0 \) )
Comparison operators:
+if (ret \( < \| <= \) 0)
> +if (ret != -EPROBE_DEFER)
Is it appropriate to treat this error code check as optional
by the shown transformation approach?
Can this case distinction be omitted?
Regards,
Markus
Powered by blists - more mailing lists