lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20200818234956.c616371d8766e74aef5e7bd2@kernel.org>
Date:   Tue, 18 Aug 2020 23:49:56 +0900
From:   Masami Hiramatsu <mhiramat@...nel.org>
To:     Jarkko Sakkinen <jarkko.sakkinen@...ux.intel.com>
Cc:     linux-kernel@...r.kernel.org, linux-mm@...ck.org,
        Andi Kleen <ak@...ux.intel.com>,
        Ard Biesheuvel <ardb@...nel.org>, Jessica Yu <jeyu@...nel.org>,
        Mark Rutland <mark.rutland@....com>,
        Masami Hiramatsu <mhiramat@...nel.org>,
        Mike Rapoport <rppt@...nel.org>,
        Peter Zijlstra <peterz@...radead.org>,
        Russell King <linux@...linux.org.uk>,
        Will Deacon <will@...nel.org>,
        Steven Rostedt <rostedt@...dmis.org>,
        Ingo Molnar <mingo@...hat.com>
Subject: Re: [PATCH] kprobes: Use module_name() macro

On Tue, 18 Aug 2020 08:08:57 +0300
Jarkko Sakkinen <jarkko.sakkinen@...ux.intel.com> wrote:

> It is advised to use module_name() macro instead of dereferencing mod->name
> directly. This makes sense for consistencys sake and also it prevents a
> hard dependency to CONFIG_MODULES.
> 
> Cc: linux-mm@...ck.org
> Cc: Andi Kleen <ak@...ux.intel.com>
> Cc: Ard Biesheuvel <ardb@...nel.org>
> Cc: Jessica Yu <jeyu@...nel.org>
> Cc: Mark Rutland <mark.rutland@....com>,
> Cc: Masami Hiramatsu <mhiramat@...nel.org>
> Cc: Mike Rapoport <rppt@...nel.org>
> Cc: Peter Zijlstra <peterz@...radead.org>
> Cc: Russell King <linux@...linux.org.uk>
> Cc: Will Deacon <will@...nel.org>
> Signed-off-by: Jarkko Sakkinen <jarkko.sakkinen@...ux.intel.com>

OK, this looks good to me.

Acked-by: Masami Hiramatsu <mhiramat@...nel.org>

Thank you,

> ---
> I thought that to get things moving it would make sense to fix this low
> hanging fruit issue first. Similarly as Masami's fix kernel/kprobes.c
> this will make my patch set less rambling, and thus easier to follow.
>  kernel/trace/trace_kprobe.c | 7 ++++---
>  1 file changed, 4 insertions(+), 3 deletions(-)
> 
> diff --git a/kernel/trace/trace_kprobe.c b/kernel/trace/trace_kprobe.c
> index aefb6065b508..19c00ee90945 100644
> --- a/kernel/trace/trace_kprobe.c
> +++ b/kernel/trace/trace_kprobe.c
> @@ -106,9 +106,10 @@ static nokprobe_inline bool trace_kprobe_has_gone(struct trace_kprobe *tk)
>  static nokprobe_inline bool trace_kprobe_within_module(struct trace_kprobe *tk,
>  						 struct module *mod)
>  {
> -	int len = strlen(mod->name);
> +	int len = strlen(module_name(mod));
>  	const char *name = trace_kprobe_symbol(tk);
> -	return strncmp(mod->name, name, len) == 0 && name[len] == ':';
> +
> +	return strncmp(module_name(mod), name, len) == 0 && name[len] == ':';
>  }
>  
>  static nokprobe_inline bool trace_kprobe_module_exist(struct trace_kprobe *tk)
> @@ -688,7 +689,7 @@ static int trace_kprobe_module_callback(struct notifier_block *nb,
>  			if (ret)
>  				pr_warn("Failed to re-register probe %s on %s: %d\n",
>  					trace_probe_name(&tk->tp),
> -					mod->name, ret);
> +					module_name(mod), ret);
>  		}
>  	}
>  	mutex_unlock(&event_mutex);
> -- 
> 2.25.1
> 


-- 
Masami Hiramatsu <mhiramat@...nel.org>

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ