lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <160151084091.310579.3876905878885019200@swboyd.mtv.corp.google.com>
Date:   Wed, 30 Sep 2020 17:07:20 -0700
From:   Stephen Boyd <sboyd@...nel.org>
To:     David Collins <collinsd@...eaurora.org>
Cc:     David Collins <collinsd@...eaurora.org>,
        linux-arm-msm@...r.kernel.org, linux-kernel@...r.kernel.org,
        Mark Brown <broonie@...nel.org>
Subject: Re: [RESEND PATCH] spmi: prefix spmi bus device names with "spmi"

Quoting David Collins (2020-09-22 15:04:18)
> Change the format of spmi bus device names from:
>   <spmi_bus_number>-<spmi_device_sid>
>   Example: 0-01
> to this:
>   spmi<spmi_bus_number>-<spmi_device_sid>
>   Example: spmi0-01
> 
> This helps to disambiguate SPMI device regmaps from I2C ones
> at /sys/kernel/debug/regmap since I2C devices use a very
> similar naming scheme: 0-0000.

Can regmap debugfs prepend the bus name on the node made in debugfs?
Does it do that already?

> 
> Signed-off-by: David Collins <collinsd@...eaurora.org>
> ---
>  drivers/spmi/spmi.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/spmi/spmi.c b/drivers/spmi/spmi.c
> index c16b60f..ec94439 100644
> --- a/drivers/spmi/spmi.c
> +++ b/drivers/spmi/spmi.c
> @@ -1,6 +1,6 @@
>  // SPDX-License-Identifier: GPL-2.0-only
>  /*
> - * Copyright (c) 2012-2015, The Linux Foundation. All rights reserved.
> + * Copyright (c) 2012-2015, 2020, The Linux Foundation. All rights reserved.
>   */
>  #include <linux/kernel.h>
>  #include <linux/errno.h>
> @@ -62,7 +62,7 @@ int spmi_device_add(struct spmi_device *sdev)
>         struct spmi_controller *ctrl = sdev->ctrl;
>         int err;
>  
> -       dev_set_name(&sdev->dev, "%d-%02x", ctrl->nr, sdev->usid);
> +       dev_set_name(&sdev->dev, "spmi%d-%02x", ctrl->nr, sdev->usid);
>  
>         err = device_add(&sdev->dev);
>         if (err < 0) {

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ