[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <6ff3bdd8-cc32-1cc0-a31a-3a3b48c87f55@gmail.com>
Date: Sat, 13 Nov 2021 10:45:33 +0530
From: Saurav Girepunje <saurav.girepunje@...il.com>
To: Dan Carpenter <dan.carpenter@...cle.com>
Cc: Larry.Finger@...inger.net, phil@...lpotter.co.uk,
gregkh@...uxfoundation.org, straube.linux@...il.com,
martin@...ser.cx, linux-staging@...ts.linux.dev,
linux-kernel@...r.kernel.org, saurav.girepunje@...mail.com
Subject: Re: [PATCH] staging: r8188eu: core: remove goto statement
On 11/11/21 12:15 am, Dan Carpenter wrote:
> On Wed, Nov 10, 2021 at 11:47:15PM +0530, Saurav Girepunje wrote:
>> Remove the goto statement from _rtw_init_recv_priv(). In this function goto
>> can be replace by return statement. As on goto label exit, function
>> only return it is not performing any cleanup. Avoiding goto will
>> improve the function readability.
>>
>> Signed-off-by: Saurav Girepunje <saurav.girepunje@...il.com>
>> ---
>> drivers/staging/r8188eu/core/rtw_recv.c | 7 ++-----
>> 1 file changed, 2 insertions(+), 5 deletions(-)
>>
>> diff --git a/drivers/staging/r8188eu/core/rtw_recv.c b/drivers/staging/r8188eu/core/rtw_recv.c
>> index 51a13262a226..b38af76f3a67 100644
>> --- a/drivers/staging/r8188eu/core/rtw_recv.c
>> +++ b/drivers/staging/r8188eu/core/rtw_recv.c
>> @@ -58,10 +58,8 @@ int _rtw_init_recv_priv(struct recv_priv *precvpriv, struct adapter *padapter)
>>
>> precvpriv->pallocated_frame_buf = vzalloc(NR_RECVFRAME * sizeof(struct recv_frame) + RXFRAME_ALIGN_SZ);
>>
>> - if (!precvpriv->pallocated_frame_buf) {
>> - res = _FAIL;
>> - goto exit;
>> - }
>> + if (!precvpriv->pallocated_frame_buf)
>> + return _FAIL;
>
>
> I hate pointless "goto exit;" labels, but there isn't a rule against
> them and I feel like this is not a good enough patch on its own. There
> is so much other stuff wrong with this function. It probably *should*
> have some error handling for example.
>
> I don't think this patch really adds enough value. Take a look at the
> function and almost every line can be improved...
>
> regards,
> dan carpenter
>
OK, I will send the other patch to improve this function,
Thanks Dan for review.
Regards,
Saurav
Powered by blists - more mailing lists