lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Wed, 22 Dec 2021 14:33:52 +0200
From:   Andy Shevchenko <andy.shevchenko@...il.com>
To:     Liam Beguin <liambeguin@...il.com>
Cc:     Peter Rosin <peda@...ntia.se>, Jonathan Cameron <jic23@...nel.org>,
        Lars-Peter Clausen <lars@...afoo.de>,
        Linux Kernel Mailing List <linux-kernel@...r.kernel.org>,
        linux-iio <linux-iio@...r.kernel.org>,
        devicetree <devicetree@...r.kernel.org>,
        Rob Herring <robh+dt@...nel.org>
Subject: Re: [PATCH v11 10/15] iio: afe: rescale: make use of units.h

On Wed, Dec 22, 2021 at 5:47 AM Liam Beguin <liambeguin@...il.com> wrote:
>
> From: Liam Beguin <lvb@...hos.com>
>
> Make use of well-defined SI metric prefixes to improve code readability.

...

>         case IIO_VAL_FRACTIONAL_LOG2:
> -               tmp = (s64)*val * 1000000000LL;
> +               tmp = (s64)*val * NANO;
>                 tmp = div_s64(tmp, rescale->denominator);
>                 tmp *= rescale->numerator;
>
> -               tmp = div_s64_rem(tmp, 1000000000LL, &rem);
> +               tmp = div_s64_rem(tmp, NANO, &rem);
>                 *val = tmp;

Thanks! The important part of this conversion is to get one trick,
i.e. NANO and GIGA are both represented by 10^9. We need to be sure
that here we use the proper sign of the power of these numbers. So
please double check in all cases that the chosen SI prefixes are
correct from the power sign point of view, e.g. it is 10^-9 and not
10^9 or otherwise.

...

>                 *val2 = rem / (int)tmp;
>                 if (rem2)
> -                       *val2 += div_s64((s64)rem2 * 1000000000LL, tmp);
> +                       *val2 += div_s64((s64)rem2 * NANO, tmp);

Ditto here and for the rest

-- 
With Best Regards,
Andy Shevchenko

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ