lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <ef3078d2-4ab5-9d5f-e1ba-42f595b3dd48@linux.intel.com>
Date: Thu, 3 Apr 2025 14:01:05 +0300 (EEST)
From: Ilpo Järvinen <ilpo.jarvinen@...ux.intel.com>
To: Derek John Clark <derekjohn.clark@...il.com>
cc: Hans de Goede <hdegoede@...hat.com>, Armin Wolf <W_Armin@....de>, 
    Jonathan Corbet <corbet@....net>, Mario Limonciello <superm1@...nel.org>, 
    Luke Jones <luke@...nes.dev>, Xino Ni <nijs1@...ovo.com>, 
    Zhixin Zhang <zhangzx36@...ovo.com>, Mia Shao <shaohz1@...ovo.com>, 
    Mark Pearson <mpearson-lenovo@...ebb.ca>, 
    "Pierre-Loup A . Griffais" <pgriffais@...vesoftware.com>, 
    "Cody T . -H . Chiu" <codyit@...il.com>, 
    John Martens <johnfanv2@...il.com>, platform-driver-x86@...r.kernel.org, 
    linux-doc@...r.kernel.org, LKML <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH v4 4/6 RESEND] platform/x86: Add Lenovo Capability Data
 01 WMI Driver

On Wed, 2 Apr 2025, Derek John Clark wrote:

> On Thu, Mar 27, 2025 at 5:56 AM Ilpo Järvinen
> <ilpo.jarvinen@...ux.intel.com> wrote:
> >
> > On Mon, 17 Mar 2025, Derek J. Clark wrote:
> >
> > > Adds lenovo-wmi-capdata01 driver which provides the
> > > LENOVO_CAPABILITY_DATA_01 WMI data block that comes on "Other Mode"
> > > enabled hardware. Provides an interface for querying if a given
> > > attribute is supported by the hardware, as well as its default_value,
> > > max_value, min_value, and step increment.
> > >
> > > Signed-off-by: Derek J. Clark <derekjohn.clark@...il.com>
> > > ---
> > > v4:
> > >  - Make driver data a private struct, remove references from Other Mode
> > >    driver.
> > >  - Don't cache data at device initialization. Instead, on component bind,
> > >    cache the data on a member variable of the Other Mode driver data
> > >    passed as a void pointer.
> > >  - Add header file for capdata01 structs.
> > >  - Add new struct to pass capdata01 array data and array length to Other
> > >    Mode.
> > > v3:
> > > - Add as component to lenovo-wmi-other driver.
> > > v2:
> > > - Use devm_kmalloc to ensure driver can be instanced, remove global
> > >   reference.
> > > - Ensure reverse Christmas tree for all variable declarations.
> > > - Remove extra whitespace.
> > > - Use guard(mutex) in all mutex instances, global mutex.
> > > - Use pr_fmt instead of adding the driver name to each pr_err.
> > > - Remove noisy pr_info usage.
> > > - Rename capdata_wmi to lenovo_wmi_cd01_priv and cd01_wmi to priv.
> > > - Use list to get the lenovo_wmi_cd01_priv instance in
> > >   lenovo_wmi_capdata01_get as none of the data provided by the macros
> > >   that will use it can pass a member of the struct for use in
> > >   container_of.
> > > ---
> > >  MAINTAINERS                                 |   2 +
> > >  drivers/platform/x86/Kconfig                |   4 +
> > >  drivers/platform/x86/Makefile               |   1 +
> > >  drivers/platform/x86/lenovo-wmi-capdata01.c | 136 ++++++++++++++++++++
> > >  drivers/platform/x86/lenovo-wmi-capdata01.h |  29 +++++
> > >  5 files changed, 172 insertions(+)
> > >  create mode 100644 drivers/platform/x86/lenovo-wmi-capdata01.c
> > >  create mode 100644 drivers/platform/x86/lenovo-wmi-capdata01.h
> > >
> > > diff --git a/MAINTAINERS b/MAINTAINERS
> > > index 6dde75922aaf..56ead241a053 100644
> > > --- a/MAINTAINERS
> > > +++ b/MAINTAINERS
> > > @@ -13164,6 +13164,8 @@ L:    platform-driver-x86@...r.kernel.org
> > >  S:   Maintained
> > >  F:   Documentation/wmi/devices/lenovo-wmi-gamezone.rst
> > >  F:   Documentation/wmi/devices/lenovo-wmi-other.rst
> > > +F:   drivers/platform/x86/lenovo-wmi-capdata01.c
> > > +F:   drivers/platform/x86/lenovo-wmi-capdata01.h
> > >  F:   drivers/platform/x86/lenovo-wmi-events.c
> > >  F:   drivers/platform/x86/lenovo-wmi-events.h
> > >  F:   drivers/platform/x86/lenovo-wmi-helpers.c
> > > diff --git a/drivers/platform/x86/Kconfig b/drivers/platform/x86/Kconfig
> > > index 13b8f4ac5dc5..64663667f0cb 100644
> > > --- a/drivers/platform/x86/Kconfig
> > > +++ b/drivers/platform/x86/Kconfig
> > > @@ -467,6 +467,10 @@ config LENOVO_WMI_HELPERS
> > >       tristate
> > >       depends on ACPI_WMI
> > >
> > > +config LENOVO_WMI_DATA01
> > > +     tristate
> > > +     depends on ACPI_WMI
> > > +
> > >  config IDEAPAD_LAPTOP
> > >       tristate "Lenovo IdeaPad Laptop Extras"
> > >       depends on ACPI
> > > diff --git a/drivers/platform/x86/Makefile b/drivers/platform/x86/Makefile
> > > index fc039839286a..7a35c77221b7 100644
> > > --- a/drivers/platform/x86/Makefile
> > > +++ b/drivers/platform/x86/Makefile
> > > @@ -69,6 +69,7 @@ obj-$(CONFIG_THINKPAD_LMI)  += think-lmi.o
> > >  obj-$(CONFIG_YOGABOOK)               += lenovo-yogabook.o
> > >  obj-$(CONFIG_YT2_1380)               += lenovo-yoga-tab2-pro-1380-fastcharger.o
> > >  obj-$(CONFIG_LENOVO_WMI_CAMERA)      += lenovo-wmi-camera.o
> > > +obj-$(CONFIG_LENOVO_WMI_DATA01)      += lenovo-wmi-capdata01.o
> > >  obj-$(CONFIG_LENOVO_WMI_EVENTS)      += lenovo-wmi-events.o
> > >  obj-$(CONFIG_LENOVO_WMI_HELPERS)     += lenovo-wmi-helpers.o
> > >
> > > diff --git a/drivers/platform/x86/lenovo-wmi-capdata01.c b/drivers/platform/x86/lenovo-wmi-capdata01.c
> > > new file mode 100644
> > > index 000000000000..b6876611ffd9
> > > --- /dev/null
> > > +++ b/drivers/platform/x86/lenovo-wmi-capdata01.c
> > > @@ -0,0 +1,136 @@
> > > +// SPDX-License-Identifier: GPL-2.0-or-later
> > > +/*
> > > + * LENOVO_CAPABILITY_DATA_01 WMI data block driver.
> >
> > Add a empty comment line here, you might want to rephrase the opening of
> > the paragraph after splitting these apart.
> >
> > > This interface provides
> > > + * information on tunable attributes used by the "Other Mode" WMI interface,
> > > + * including if it is supported by the hardware, the default_value, max_value,
> > > + * min_value, and step increment.
> > > + *
> > > + * Copyright(C) 2025 Derek J. Clark <derekjohn.clark@...il.com>
> > > + */
> > > +
> > > +#include <linux/cleanup.h>
> > > +#include <linux/component.h>
> > > +#include <linux/container_of.h>
> > > +#include <linux/device.h>
> > > +#include <linux/gfp_types.h>
> > > +#include <linux/types.h>
> > > +#include <linux/wmi.h>
> >
> > Add an empty line here please.
> >
> > > +#include "lenovo-wmi-capdata01.h"
> > > +
> > > +/* Interface GUIDs */
> > > +#define LENOVO_CAPABILITY_DATA_01_GUID "7A8F5407-CB67-4D6E-B547-39B3BE018154"
> > > +
> > > +struct lwmi_cd01_priv {
> > > +     struct wmi_device *wdev;
> > > +};
> > > +
> > > +/*
> > > + * lenovo_cd01_component_bind() - On master bind, caches all capability data on
> > > + * the master device.
> >
> > Is this "On master bind" something that the caller should be doing? IMO,
> > that would belong to description paragraph instead of the function
> > summary.
> >
> 
> Acked
> 
> > > + * @cd01_dev: Pointer to the capability data 01 parent device.
> > > + * @om_dev: Pointer to the other mode parent device.
> > > + * @data: capdata01_list object pointer to return the capability data with.
> > > + *
> > > + * Returns: 0, or an error.
> >
> > Return:
> >
> > > + */
> > > +static int lenovo_cd01_component_bind(struct device *cd01_dev,
> > > +                                   struct device *om_dev, void *data)
> > > +{
> > > +     struct lwmi_cd01_priv *priv = dev_get_drvdata(cd01_dev);
> > > +     int count, idx;
> > > +
> > > +     if (!priv)
> > > +             return -ENODEV;
> > > +
> > > +     count = wmidev_instance_count(priv->wdev);
> > > +
> > > +     if (count == 0)
> > > +             return -EINVAL;
> > > +
> > > +     ((struct cd01_list *)data)->count = count;
> >
> > Please create a local variable with the correct type and since data is
> > void *, you don't need to cast it while assigning to that local variable.
> >
> 
> This will be reworked a bit with Armin's suggestions.
> 
> > > +     ((struct cd01_list *)data)->data = devm_kmalloc_array(om_dev, count,
> > > +                                                           sizeof(struct capdata01 *),
> >
> > sizeof() should preferrably take the type directly from ->data (with the
> > correct amount of * chars).
> >
> 
> With Armin's suggestion I'll be using struct_size, but I'll note this
> for future reference, thanks.
> 
> > > +                                                           GFP_KERNEL);
> > > +     if (!data)
> > > +             return -ENOMEM;
> > > +
> > > +     for (idx = 0; idx < count; idx++) {
> > > +             union acpi_object *ret_obj __free(kfree) = NULL;
> > > +
> > > +             ret_obj = wmidev_block_query(priv->wdev, idx);
> > > +             if (!ret_obj) {
> > > +                     ((struct cd01_list *)data)->data[idx] = NULL;
> > > +                     continue;
> > > +             }
> > > +             if (ret_obj->type != ACPI_TYPE_BUFFER) {
> > > +                     ((struct cd01_list *)data)->data[idx] = NULL;
> > > +                     continue;
> > > +             }
> > > +
> > > +             if (ret_obj->buffer.length != sizeof(struct capdata01)) {
> >
> > You could consider joining these 3 if()s with || to avoid having to
> > repeat the NULL assignment and continue.
> >
> 
> devm_kzalloc will take care of the NULL assignment going forward. for
> !ret_obj, should I return an error here instead? It seems like a
> problem if that fails.

Sure, if you think something is an indication of a bigger problem that 
requires giving up.


BTW, in general (not related to this particular comment), you don't have 
reply/ack those review comments you're going to implement as I suggested. 
I trust you to make the changes you don't contest :-).

That way, we can focus on the points that need further discussion.

-- 
 i.

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ