lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <f845e90c-50ff-4e0f-9b73-55a704ba934f@linux.dev>
Date: Thu, 3 Apr 2025 15:33:10 +0200
From: Zhu Yanjun <yanjun.zhu@...ux.dev>
To: "Zhijian Li (Fujitsu)" <lizhijian@...itsu.com>,
 "linux-rdma@...r.kernel.org" <linux-rdma@...r.kernel.org>
Cc: "linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
 "zyjzyj2000@...il.com" <zyjzyj2000@...il.com>, "jgg@...pe.ca"
 <jgg@...pe.ca>, "leon@...nel.org" <leon@...nel.org>,
 "Daisuke Matsuda (Fujitsu)" <matsuda-daisuke@...itsu.com>,
 Shin'ichiro Kawasaki <shinichiro.kawasaki@....com>
Subject: Re: [PATCH] RDMA/rxe: Fix null pointer dereference in ODP MR check

在 2025/4/3 4:59, Zhijian Li (Fujitsu) 写道:
> 
> 
> On 02/04/2025 16:58, Zhu Yanjun wrote:
>>
>> Previously I once discussed with Bob Pearson about the function names.
> 
> This is a frequently raised question, yet I have not discovered a definitive
> coding style(Please let me know if you have). According to my understanding,
> the common practice I adhere to is as follows:
> 

You have your own principals. In the linux rdma maillist, there is no 
such common principals. From the debug perspective, it is better to add 
rxe_ prefix to make debuf life easier. But if you follow your advice to 
choose not to add rxe_ prefix, it is also OK. After all, no such 
principals exist currently.

Zhu Yanjun

> - Functions utilized within a single file often do not require a prefix, as current situation.
> - If a function is to be used across multiple files, I believe a prefix is essential.
> 
> Thanks
> Zhijian
> 
>> Perhaps it is better to rename is_odp_mr to rxe_is_odp_mr?
>>
>> Since sometimes we debug in rdma, with a lot of functions with the same name, it is difficult to recognize the modules that this function belongs to.
>>
>> Thus, in rxe module, it is better to add rxe_ prefix to the function name. But anyway, this commit is fine.


Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ