lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date:	Sat, 13 Jan 2007 02:45:43 -0500
From:	Pavel Roskin <proski@....org>
To:	Michael Buesch <mb@...sch.de>
Cc:	bcm43xx-dev@...ts.berlios.de, netdev@...r.kernel.org
Subject: Re: What is in bcm43xx-wireless-dev.git?

Quoting Michael Buesch <mb@...sch.de>:

> > drivers/ssb/driver_mips/mips.c includes asm/time.h, which is missing on
> > x86_64.  It also refers to struct ssb_serial_ports, which is not defined
> > anywhere.
>
> Yeah, CONFIG_SSB_MIPS should depend on the MIPS CPU.
> Which kconfig option do you suggest to make a "depend" on?

I try not to add artificial restrictions.  The driver should depend on the
components providing the necessary API.

It's better to allow compiling the driver for as many configurations as
possible, so that it could be compile tested after massive updates.  It would
also be useful for checking the code with tools like sparse.

It's not hard to come up with more portable alternatives to asm/time.h.

> > drivers/ssb/driver_pci/pcicore.c refers to SSB_PCICORE_SBTOPCI1_CFG1
> > that is not defined anywhere in the kernel.
>
> Yeah, could be a typo. I'll have a look at it.

I only found it because the driver didn't depend on MIPS.  See what I mean?

This only manifests if CONFIG_SSB_PCICORE_HOSTMODE is defined, and it is only
selected by CONFIG_SSB_DRIVER_MIPS.

> Hm, not sure why this oopses. It works on PPC (can transmit data and so on).

My PPC machine is a venerable Blue&White G3, so it won't take PCIe.

> You can disable that. I think that should probably depend
> on CONFIG_SSB_DRIVER_MIPS. I'll take a look.

OK, disabled.

> Does it work with linville's tree (in DMA mode)?

Yes, it does.  I couldn't connect to the AP, but it's a different story.  I may
be doing things wrong.  At least I can scan and I see the APs around.

I'm using an AP with 128-bit WEP.  Setting the key and the ESSID is not
sufficient to associate.  I tried wpa_supplicant, but it won't associate
either.  The kernel messages and the wpa_supplicant output are attached.  I
could not compile wpa_supplicant with MLME (too much code to fix), but I don't
think it should be required.

I tried the current version from your branch without SMP, but it still crashes
in dma_alloc_coherent (also attached).

--
Regards,
Pavel Roskin

Download attachment "wpa_supplicant.output" of type "application/octet-stream" (843 bytes)

View attachment "d80211.log" of type "text/x-log" (3657 bytes)

Download attachment "bcm43xx_d80211-oops-dma-nosmp" of type "application/octet-stream" (3464 bytes)

Powered by blists - more mailing lists