[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20150923103859.GA29016@hmsreliant.think-freely.org>
Date: Wed, 23 Sep 2015 06:39:00 -0400
From: Neil Horman <nhorman@...driver.com>
To: Stephen Hemminger <stephen@...workplumber.org>
Cc: Neil Horman <nhorman@...hat.com>, netdev@...r.kernel.org
Subject: Re: [PATCH v2] netpoll: Close race condition between poll_one_napi
and napi_disable
On Tue, Sep 22, 2015 at 03:09:20PM -0700, Stephen Hemminger wrote:
> On Tue, 22 Sep 2015 16:01:36 -0400
> Neil Horman <nhorman@...hat.com> wrote:
>
> > + clear_bit(NAPI_STATE_NPSVC, &n->state);
> > +
> > }
> why introduce extra line here?
>
> > + /*
> > + * If we set this bit but see that it has already been set,
> > + * that indicates that napi has been disabled and we need
> > + * to abort this operation
> > + */
> > +
> > + if(test_and_set_bit(NAPI_STATE_NPSVC, &napi->state))
>
> And why introduce line after comment before code.
> My preference is to have comment as close to code as possible.
Mine is to add spaces, as I feel the code is more readable if its a bit more
spread out.
> --
> To unsubscribe from this list: send the line "unsubscribe netdev" in
> the body of a message to majordomo@...r.kernel.org
> More majordomo info at http://vger.kernel.org/majordomo-info.html
>
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists