[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20200723170842.GB2975@hoboy>
Date: Thu, 23 Jul 2020 10:08:42 -0700
From: Richard Cochran <richardcochran@...il.com>
To: Kurt Kanzenbach <kurt@...utronix.de>
Cc: Andrew Lunn <andrew@...n.ch>,
Vivien Didelot <vivien.didelot@...il.com>,
Florian Fainelli <f.fainelli@...il.com>,
"David S. Miller" <davem@...emloft.net>,
Jakub Kicinski <kuba@...nel.org>, netdev@...r.kernel.org
Subject: Re: [PATCH v1 0/2] ptp: Add generic header parsing function
Kurt,
On Thu, Jul 23, 2020 at 09:49:44AM +0200, Kurt Kanzenbach wrote:
> in order to reduce code duplication in the ptp code of DSA drivers, move the
> header parsing function to ptp_classify. This way the Marvell and the hellcreek
> drivers can share the same implementation. And probably more drivers can benefit
> from it. Implemented as discussed [1] [2].
This looks good. I made a list of drivers that can possibily use this helper.
Finding symbol: PTP_CLASS_PMASK
*** drivers/net/dsa/mv88e6xxx/hwtstamp.c:
parse_ptp_header[223] switch (type & PTP_CLASS_PMASK) {
*** drivers/net/ethernet/mellanox/mlxsw/spectrum_ptp.c:
mlxsw_sp_ptp_parse[335] switch (ptp_class & PTP_CLASS_PMASK) {
*** drivers/net/ethernet/ti/am65-cpts.c:
am65_skb_get_mtype_seqid[761] switch (ptp_class & PTP_CLASS_PMASK) {
*** drivers/net/ethernet/ti/cpts.c:
cpts_skb_get_mtype_seqid[459] switch (ptp_class & PTP_CLASS_PMASK) {
*** drivers/net/phy/dp83640.c:
match[815] switch (type & PTP_CLASS_PMASK) {
is_sync[990] switch (type & PTP_CLASS_PMASK) {
*** drivers/ptp/ptp_ines.c:
ines_match[457] switch (ptp_class & PTP_CLASS_PMASK) {
is_sync_pdelay_resp[703] switch (type & PTP_CLASS_PMASK) {
> @DSA maintainers: Please, have a look the Marvell code. I don't have hardware to
> test it. I've tested this series only on the Hirschmann switch.
I'll test the marvell switch with your change and let you know...
Thanks,
Richard
Powered by blists - more mailing lists