[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <2439d9ab-133f-0338-24f9-a9a5cd2065a3@datenfreihafen.org>
Date: Fri, 7 Jan 2022 14:46:43 +0100
From: Stefan Schmidt <stefan@...enfreihafen.org>
To: Pavel Skripkin <paskripkin@...il.com>, alex.aring@...il.com,
davem@...emloft.net, kuba@...nel.org, linux-wpan@...r.kernel.org,
netdev@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH -next] ieee802154: atusb: move to new USB API
Hello.
On 05.01.22 15:49, Pavel Skripkin wrote:
> @@ -176,9 +105,13 @@ static int atusb_read_subreg(struct atusb *lp,
> unsigned int addr, unsigned int mask,
> unsigned int shift)
> {
> - int rc;
> + int rc, ret;
> +
> + ret = usb_control_msg_recv(lp->usb_dev, 0, ATUSB_REG_READ, ATUSB_REQ_FROM_DEV,
You are changing the meaning of the rc variable away from a return code.
Its the register value now. I would prefer if we change the name to
something like reg to reflect this new meaning.
> + 0, addr, &rc, 1, 1000, GFP_KERNEL);
> + if (ret < 0)
> + return ret;
>
> - rc = atusb_read_reg(lp, addr);
> rc = (rc & mask) >> shift;
>
> return rc;
The change above and the bug fix I reported the other day is all that is
missing for this to be applied. You want to send a v2 with this changes
or do you prefer me doing them here locally and apply?
regards
Stefan Schmidt
Powered by blists - more mailing lists