lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Sat, 8 Jan 2022 16:11:30 +0300
From:   Pavel Skripkin <paskripkin@...il.com>
To:     Stefan Schmidt <stefan@...enfreihafen.org>, alex.aring@...il.com,
        davem@...emloft.net, kuba@...nel.org, linux-wpan@...r.kernel.org,
        netdev@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH -next] ieee802154: atusb: move to new USB API

Hi Stefan,

On 1/7/22 16:46, Stefan Schmidt wrote:
> 
> Hello.
> 
> On 05.01.22 15:49, Pavel Skripkin wrote:
>> @@ -176,9 +105,13 @@ static int atusb_read_subreg(struct atusb *lp,
>>   			     unsigned int addr, unsigned int mask,
>>   			     unsigned int shift)
>>   {
>> -	int rc;
>> +	int rc, ret;
>> +
>> +	ret = usb_control_msg_recv(lp->usb_dev, 0, ATUSB_REG_READ, ATUSB_REQ_FROM_DEV,
> 
> You are changing the meaning of the rc variable away from a return code.
> Its the register value now. I would prefer if we change the name to
> something like reg to reflect this new meaning.
> 

Ack. Will fix in v2.

>> +				   0, addr, &rc, 1, 1000, GFP_KERNEL);
>> +	if (ret < 0)
>> +		return ret;
>>   
>> -	rc = atusb_read_reg(lp, addr);
>>   	rc = (rc & mask) >> shift;
>>   
>>   	return rc;
> 
> The change above and the bug fix I reported the other day is all that is
> missing for this to be applied. You want to send a v2 with this changes
> or do you prefer me doing them here locally and apply?
> 

I am going to send v2 soon. Thank you for review!




With regards,
Pavel Skripkin

Powered by blists - more mailing lists