[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <ZBHD2J8I1WGf9gnB@nimitz>
Date: Wed, 15 Mar 2023 14:10:48 +0100
From: Piotr Raczynski <piotr.raczynski@...el.com>
To: Saeed Mahameed <saeed@...nel.org>
CC: "David S. Miller" <davem@...emloft.net>,
Jakub Kicinski <kuba@...nel.org>,
Paolo Abeni <pabeni@...hat.com>,
Eric Dumazet <edumazet@...gle.com>,
"Saeed Mahameed" <saeedm@...dia.com>, <netdev@...r.kernel.org>,
Tariq Toukan <tariqt@...dia.com>,
Parav Pandit <parav@...dia.com>,
Daniel Jurgens <danielj@...dia.com>
Subject: Re: [net 03/14] net/mlx5: Fix setting ec_function bit in MANAGE_PAGES
On Tue, Mar 14, 2023 at 10:49:29AM -0700, Saeed Mahameed wrote:
> From: Parav Pandit <parav@...dia.com>
>
> When ECPF is a page supplier, reclaim pages missed to honor the
> ec_function bit provided by the firmware. It always used the ec_function
> to true during driver unload flow for ECPF. This is incorrect.
>
> Honor the ec_function bit provided by device during page allocation
> request event.
>
> Fixes: d6945242f45d ("net/mlx5: Hold pages RB tree per VF")
> Signed-off-by: Parav Pandit <parav@...dia.com>
> Signed-off-by: Daniel Jurgens <danielj@...dia.com>
> Signed-off-by: Saeed Mahameed <saeedm@...dia.com>
> ---
> .../ethernet/mellanox/mlx5/core/pagealloc.c | 18 ++++++++++++++----
> 1 file changed, 14 insertions(+), 4 deletions(-)
>
> diff --git a/drivers/net/ethernet/mellanox/mlx5/core/pagealloc.c b/drivers/net/ethernet/mellanox/mlx5/core/pagealloc.c
> index 64d4e7125e9b..bd2712b2317d 100644
> --- a/drivers/net/ethernet/mellanox/mlx5/core/pagealloc.c
> +++ b/drivers/net/ethernet/mellanox/mlx5/core/pagealloc.c
> @@ -82,6 +82,16 @@ static u16 func_id_to_type(struct mlx5_core_dev *dev, u16 func_id, bool ec_funct
> return func_id <= mlx5_core_max_vfs(dev) ? MLX5_VF : MLX5_SF;
> }
>
> +static u32 get_ec_function(u32 function)
> +{
> + return function >> 16;
> +}
> +
> +static u32 get_func_id(u32 function)
> +{
> + return function & 0xffff;
> +}
> +
Some code in this file is mlx5 'namespaced', some is not. It may be a
little easier to follow the code knowing explicitly whether it is driver
vs core code, just something to consider.
Other than that, looks fine, thanks.
Reviewed-by: Piotr Raczynski <piotr.raczynski@...el.com>
> static struct rb_root *page_root_per_function(struct mlx5_core_dev *dev, u32 function)
> {
> struct rb_root *root;
> @@ -665,7 +675,7 @@ static int optimal_reclaimed_pages(void)
> }
>
> static int mlx5_reclaim_root_pages(struct mlx5_core_dev *dev,
> - struct rb_root *root, u16 func_id)
> + struct rb_root *root, u32 function)
> {
> u64 recl_pages_to_jiffies = msecs_to_jiffies(mlx5_tout_ms(dev, RECLAIM_PAGES));
> unsigned long end = jiffies + recl_pages_to_jiffies;
> @@ -674,11 +684,11 @@ static int mlx5_reclaim_root_pages(struct mlx5_core_dev *dev,
> int nclaimed;
> int err;
>
> - err = reclaim_pages(dev, func_id, optimal_reclaimed_pages(),
> - &nclaimed, false, mlx5_core_is_ecpf(dev));
> + err = reclaim_pages(dev, get_func_id(function), optimal_reclaimed_pages(),
> + &nclaimed, false, get_ec_function(function));
> if (err) {
> mlx5_core_warn(dev, "failed reclaiming pages (%d) for func id 0x%x\n",
> - err, func_id);
> + err, get_func_id(function));
> return err;
> }
>
> --
> 2.39.2
>
Powered by blists - more mailing lists